USA PoP is currently experiencing degraded service due to a DDoS attack.
Resolved
Jul 26, 2026 at 3:45am UTC
The incident has been fully resolved.
Mitigation has been successfully applied across all affected locations, and traffic has remained stable. All services, including the New York and Miami PoPs, are now operating normally.
Thank you for your patience while we worked to mitigate the attack and restore full network stability.
Affected services
Updated
Jul 26, 2026 at 3:33am UTC
Mitigation has been implemented across all locations, and traffic levels have returned to normal.
Some minor network variance may continue while the mitigation measures fully stabilize. Affected users may notice temporary latency fluctuations, intermittent packet loss, inconsistent ICMP or ping responses, or brief routing changes.
All services are currently operating normally, and we will continue monitoring traffic closely to ensure the network remains stable.
Affected services
Created
Jul 26, 2026 at 3:28am UTC
We are currently mitigating a DDoS attack against our New York and Miami PoP clusters. The attack briefly peaked at approximately 4.57 Tb/s and 573 million packets per second during a 30-second window.
Additional filtering has been applied. Users routed through New York or Miami may experience degraded connectivity or temporary unavailability while mitigation is in progress.
We are actively monitoring the situation and will share further updates as more information becomes available.
Affected services