Back to overview
Resolved

Frankfurt PoP is currently experiencing degraded service due to a DDoS attack.

Jul 4, 2026 at 3:12am UTC
Affected services
Frankfurt Anycast Edge

Resolved
Jul 4, 2026 at 3:56am UTC

The issue has been fully resolved.

Mitigation has been successfully applied across all affected locations, and traffic has remained stable. Services are now operating normally, including the Frankfurt PoP.

Thank you for your patience while we worked to mitigate the attack and restore full stability.

Updated
Jul 4, 2026 at 3:22am UTC

We have implemented mitigation across all locations, and traffic levels have returned to normal.

Some temporary network variance may still be observed while mitigation fully stabilizes. This may include fluctuating latency, occasional packet loss, ICMP/ping inconsistencies, or route changes for some users.

Services are operating normally, and we are continuing to monitor traffic closely to ensure full stability.

Created
Jul 4, 2026 at 3:12am UTC

We are currently mitigating a DDoS attack against our Frankfurt PoP Cluster. The attack briefly peaked at approximately 2.14 Tb/s and 361 million packets per second during a 90-second window.

Additional filtering has been applied, and our upstream provider has been notified to assist with mitigation. Users routed through Frankfurt may experience degraded connectivity or temporary unavailability while mitigation is in progress.

We are actively monitoring the situation and will share updates as more information becomes available.